NetSight
low2.6Public exploit code

CVE-2008-4456

Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, wh…

Public exploit code

Working exploit or proof of concept code has been published for this vulnerability. Treat unpatched systems as at risk.

Impact

Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.

Affected products

VendorProductAffected versions
MysqlMysql
Versions 5.0.4, 5.0.30, 5.0.36, 5.0.44
OracleMysql
Versions 5.0.26, 5.0.27, 5.0.30, 5.0.32, 5.0.33, 5.0.37

Weakness classification

References