NetSight
critical6.8

CVE-2013-6393

Heap Based Buffer Overflow in libyaml

Impact

Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags. ## Recommendation - Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.

Affected packages

EcosystemPackageAffectedFixed in
npmlibyaml< 0.2.30.2.3

Affected products

VendorProductAffected versions
PyyamlLibyaml
through 0.1.4
Versions 0.0.1, 0.1.1, 0.1.2, 0.1.3
CanonicalUbuntu Linux
Versions 12.04, 12.10, 13.10
RedhatOpenstack
Versions 3.0, 4.0
DebianDebian Linux
Versions 6.0, 7.0
OpensuseLeap
Version 42.1
OpensuseOpensuse
Versions 11.4, 13.1, 13.2

Weakness classification

References