NetSight
critical9.8

CVE-2013-7378

Potential Command Injection in hubot-scripts

Impact

Versions 2.4.3 and earlier of hubot-scripts are vulnerable to a command injection vulnerablity in the `hubot-scripts/package/src/scripts/email.coffee` module. ### Mitigating Factors The email script is not enabled by default, it has to be manually added to hubot's list of loaded scripts. ## Recommendation Update hubot-scripts to version 2.4.4 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmhubot-scripts<= 2.4.32.4.5

Affected products

VendorProductAffected versions
Hubot Scripts ProjectHubot Scripts
before 2.4.4

Weakness classification

References