medium6.1
CVE-2014-3743
Multiple Content Injection Vulnerabilities in marked
Impact
Versions 0.3.0 and earlier of `marked` are affected by two cross-site scripting vulnerabilities, even when `sanitize: true` is set. The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs. ## Recommendation Upgrade to version 0.3.1 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | marked | <= 0.3.0 | 0.3.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Marked Project | Marked | before 0.3.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- http://www.openwall.com/lists/oss-security/2014/05/15/2
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-3743
- https://nodesecurity.io/advisories/marked_multiple_content_injection_vulnerabilities
- https://github.com/advisories/GHSA-9cw2-jqp5-7x39
- https://nvd.nist.gov/vuln/detail/CVE-2014-1850
- https://www.npmjs.com/advisories/22