NetSight
medium6.1

CVE-2015-8856

Cross-Site Scripting in serve-index

Impact

Versions 1.6.2 and earlier of `serve-index` are affected by a cross-site scripting vulnerability. Because file and directory names are not escaped in the module's HTML output, a remote attacker that can influence file or directory names can launch a persistent cross-site scripting attack on the application. ## Recommendation Update to version 1.6.3 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmserve-index< 1.6.31.6.3

Affected products

VendorProductAffected versions
OpenjsfServe-Index
before 1.6.3

Weakness classification

References