critical9.8
CVE-2015-8857
Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js
Impact
Versions of `uglify-js` prior to 2.4.24 are affected by a vulnerability which may cause crafted JavaScript to have altered functionality after minification. ## Recommendation Upgrade UglifyJS to version >= 2.4.24.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | uglify-js | < 2.4.24 | 2.4.24 |
| rubygems | uglifier | < 2.7.2 | 2.7.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Uglifyjs Project | Uglifyjs | before 2.4.24 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- http://www.securityfocus.com/bid/96410
- https://nodesecurity.io/advisories/39
- https://github.com/advisories/GHSA-34r7-q49f-h37c
- https://nvd.nist.gov/vuln/detail/CVE-2015-8857
- https://github.com/mishoo/UglifyJS2/issues/751
- https://zyan.scripts.mit.edu/blog/backdooring-js/
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/uglifier/CVE-2015-8857.yml
- https://web.archive.org/web/20200227190830/http://www.securityfocus.com/bid/96410
- https://github.com/lautis/uglifier/commit/4677bfe38142937ff952f95605bcec4618892c3e