NetSight
high7.5

CVE-2015-9240

Authentication Weakness in keystone

Impact

Versions of `keystone` prior to 0.3.16 are affected by a partial authentication bypass vulnerability. In the default sign in functionality, if an attacker provides a full and correct password, yet only provides part of the associated email address, authentication will be granted. ## Recommendation Update to version 0.3.16 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmkeystone< 0.3.160.3.16

Affected products

VendorProductAffected versions
KeystonejsKeystone
before 0.3.16

Weakness classification

References