NetSight
high8.8

CVE-2016-10529

No CSRF Validation in droppy

Impact

Affected versions of `droppy` are vulnerable to cross-site socket forgery. The package does not perform verification for cross-domain websocket requests, and as a result, an attacker can create a web page that opens up a websocket connection on behalf of the user visiting the page. The attacker can then perform any action that the target user could, including adding a new admin account under their control, or deleting others. ## Recommendation Update to version 3.5.0 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmdroppy< 3.5.03.5.0

Affected products

VendorProductAffected versions
Droppy ProjectDroppy
before 3.5.0

Weakness classification

References