NetSight
medium5.4

CVE-2016-10537

Cross-Site Scripting in backbone

Impact

Affected versions of `backbone` are vulnerable to cross-site scripting when users are allowed to supply input to the `Model#Escape` function, and the output is then written to the DOM. The vulnerability occurs as a result of the regular expression used to encode metacharacters failing to take HTML Entities such as `<` into account. ## Recommendation Update to version 0.5.0 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmbackbone>= 0.3.3, < 0.5.00.5.0

Affected products

VendorProductAffected versions
Backbone ProjectBackbone
through 0.3.3

Weakness classification

References