NetSight
critical9.8

CVE-2016-10550

SQL Injection in sequelize

Impact

Affected versions of `sequelize` are vulnerable to SQL Injection in locations where user input is passed into the `limit` or `order` parameters of `sequelize` query calls, such as `findOne` or `findAll`. ## Recommendation Update to version 3.17.0 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmsequelize< 3.17.03.17.0

Affected products

VendorProductAffected versions
SequelizejsSequelize
through 3.16.0

Weakness classification

References