critical9.8
CVE-2016-10551
SQL Injection in waterline-sequel
Impact
Affected versions of `waterline-sequel` are vulnerable to SQL injection in cases where user input is passed into the `like`, `contains`, `startsWith`, or `endsWith` methods. ## Recommendation Upgrade to at least version 0.5.1
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | waterline-sequel | < 0.5.1 | 0.5.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Balderdash | Waterline-Sequel | Version 0.5.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/balderdashy/waterline/issues/1219#issuecomment-157294530
- https://nodesecurity.io/advisories/115
- https://github.com/advisories/GHSA-cgpp-wm2h-6hqx
- https://nvd.nist.gov/vuln/detail/CVE-2016-10551
- https://github.com/balderdashy/waterline-sequel/pull/66
- https://www.npmjs.com/advisories/115