critical9.8
CVE-2016-10554
SQL Injection in sequelize
Impact
Affected versions of `sequelize` use MySQL's backslash-based escape syntax when connecting to SQLite, despite the fact that SQLite uses PostgreSQL's escape syntax, which can result in a SQL Injection vulnerability. ## Recommendation Update to version 1.7.0-alpha3 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | sequelize | <= 1.7.0-alpha2 | 1.7.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Sequelizejs | Sequelize | through 1.6.0 Version 1.7.0 |