NetSight
medium5.5

CVE-2016-15020

A vulnerability was found in liftkit database up to 2.13.1.

Impact

A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The patch is named 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.

Affected products

VendorProductAffected versions
Liftkit Database Library ProjectLiftkit Database Library
before 2.13.2

Weakness classification

References