high7.5
CVE-2016-5697
Ruby-saml allows attackers to perform XML signature wrapping attacks
Impact
ruby-saml prior to version 1.3.0 is vulnerable to an XML signature wrapping attack in the specific scenario where there was a signature that referenced at the same time 2 elements (but past the scheme validator process since 1 of the element was inside the encrypted assertion). ruby-saml users must update to 1.3.0, which implements 3 extra validations to mitigate this kind of attack.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | ruby-saml | < 1.3.0 | 1.3.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Onelogin | Ruby-Saml | through 1.2.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2016/06/24/3
- https://github.com/advisories/GHSA-36p7-xjw8-h6f2
- https://nvd.nist.gov/vuln/detail/CVE-2016-5697
- https://github.com/onelogin/ruby-saml/commit/a571f52171e6bfd87db59822d1d9e8c38fb3b995
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2016-5697.yml