high8.1
CVE-2016-7191
Authentication Bypass in passport-azure-ad
Impact
Affected versions of `passport-azure-ad` do not recognize the `validateIssuer` setting, which allows remote attackers to bypass authentication via a crafted token. ## Recommendation Version 1.x: Update to version 1.4.6 or later. Version 2.x: Update to version 2.0.1 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | passport-azure-ad | >= 1.0.0, < 1.4.6 | 1.4.6 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Microsoft | Azure Active Directory Passport | Versions 1.0.0, 1.1.0, 1.1.1, 1.2.0, 1.3.0, 1.3.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.securityfocus.com/bid/93213
- http://www.securitytracker.com/id/1036996
- https://github.com/AzureAD/passport-azure-ad/blob/master/SECURITY-NOTICE.MD
- https://support.microsoft.com/kb/3187742
- https://github.com/advisories/GHSA-73jp-3c67-hjfv
- https://nvd.nist.gov/vuln/detail/CVE-2016-7191
- https://support.microsoft.com/en-us/kb/3187742
- https://www.npmjs.com/advisories/151