NetSight
critical9.8

CVE-2017-0899

RubyGems Code Injection vulnerability

Impact

RubyGems prior to 2.6.13 is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

Affected packages

EcosystemPackageAffectedFixed in
rubygemsrubygems-update< 2.6.132.6.13

Affected products

VendorProductAffected versions
RubygemsRubygems
through 2.6.12
DebianDebian Linux
Versions 8.0, 9.0
RedhatEnterprise Linux Desktop
Version 7.0
RedhatEnterprise Linux Server
Version 7.0
RedhatEnterprise Linux Server Aus
Versions 7.4, 7.6
RedhatEnterprise Linux Server Eus
Versions 7.4, 7.5, 7.6
RedhatEnterprise Linux Server Tus
Versions 7.4, 7.6
RedhatEnterprise Linux Workstation
Version 7.0

Weakness classification

References