NetSight
high7.0

CVE-2017-1000376

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack.

Impact

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.

Affected products

VendorProductAffected versions
RedhatEnterprise Virtualization Server
All versions
RedhatOpenshift
Version 2.0
RedhatEnterprise Linux
Versions 6.0, 7.0
DebianDebian Linux
Versions 8.0, 9.0
Libffi ProjectLibffi
before 3.2
OraclePeopletools
Versions 8.56, 8.57

Weakness classification

References