high7.5
CVE-2017-16014
Insufficient Error Handling in http-proxy
Impact
Affected versions of `http-proxy` are vulnerable to a denial of service attack, wherein an attacker can force an error which will cause the server to crash. ## Recommendation Update to version 0.7.0 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | http-proxy | <= 0.6.6 | 0.7.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Http-Proxy Project | Http-Proxy | before 0.7.0 |