high5.9
CVE-2017-16025
Denial of Service in nes
Impact
Affected versions of `nes` are vulnerable to denial of service when given an invalid `cookie` header, and websocket authentication is set to `cookie`. Submitting an invalid cookie on the websocket upgrade request will cause the node process to throw and exit. ## Recommendation Update to version 6.4.1 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | nes | <= 6.4.0 | 6.4.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Hapijs | Nes | through 6.4.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/hapijs/nes/commit/249ba1755ed6977fbc208463c87364bf884ad655
- https://github.com/hapijs/nes/issues/171
- https://nodesecurity.io/advisories/331
- https://github.com/advisories/GHSA-3pwh-5mmc-mwrx
- https://nvd.nist.gov/vuln/detail/CVE-2017-16025
- https://www.npmjs.com/advisories/331