critical9.8
CVE-2017-16042
Growl before 1.10.0 vulnerable to Command Injection
Impact
Affected versions of `growl` do not properly sanitize input prior to passing it into a shell command, allowing for arbitrary command execution. ## Recommendation Update to version 1.10.0 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | growl | < 1.10.0 | 1.10.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Growl Project | Growl | before 1.10.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/tj/node-growl/issues/60
- https://github.com/tj/node-growl/pull/61
- https://nodesecurity.io/advisories/146
- https://github.com/advisories/GHSA-qh2h-chj9-jffq
- https://nvd.nist.gov/vuln/detail/CVE-2017-16042
- https://www.npmjs.com/advisories/146
- https://github.com/tj/node-growl/pull/62
- https://github.com/tj/node-growl/commit/d71177d5331c9de4658aca62e0ac921f178b0669