NetSight
medium5.3

CVE-2017-16137

Regular Expression Denial of Service in debug

Impact

Affected versions of `debug` are vulnerable to regular expression denial of service when untrusted user input is passed into the `o` formatter. As it takes 50,000 characters to block the event loop for 2 seconds, this issue is a low severity issue. This was later re-introduced in version v3.2.0, and then repatched in versions 3.2.7 and 4.3.1. ## Recommendation Version 2.x.x: Update to version 2.6.9 or later. Version 3.1.x: Update to version 3.1.0 or later. Version 3.2.x: Update to version 3.2.7 or later. Version 4.x.x: Update to version 4.3.1 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmdebug< 2.6.92.6.9

Affected products

VendorProductAffected versions
Debug ProjectDebug
from 2.0.0 before 2.6.9
from 3.0.0 before 3.1.0

Weakness classification

References