high7.5
CVE-2017-18214
Regular Expression Denial of Service in moment
Impact
Affected versions of `moment` are vulnerable to a low severity regular expression denial of service when parsing dates as strings. ## Recommendation Update to version 2.19.3 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | moment | < 2.19.3 | 2.19.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Momentjs | Moment | through 2.19.2 |
| Tenable | Nessus | through 8.2.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/moment/moment/issues/4163
- https://nodesecurity.io/advisories/532
- https://www.tenable.com/security/tns-2019-02
- https://github.com/advisories/GHSA-446m-mv8f-q348
- https://nvd.nist.gov/vuln/detail/CVE-2017-18214
- https://github.com/moment/moment/pull/4326
- https://www.npmjs.com/advisories/532
- https://github.com/moment/moment/commit/69ed9d44957fa6ab12b73d2ae29d286a857b80eb