NetSight
high8.8

CVE-2017-7297

Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call.

Impact

Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.

Affected products

VendorProductAffected versions
SuseRancher
from 1.2.0 before 1.2.4
from 1.3.0 before 1.3.5
from 1.4.0 before 1.4.3
from 1.5.0 before 1.5.3

References