high7.5
CVE-2018-1000024
The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response…
Impact
The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can result in Denial of Service for all clients using the proxy.. This attack appear to be exploitable via Remote server delivers an HTTP response payload containing valid but unusual ESI syntax.. This vulnerability appears to have been fixed in 4.0.23 and later.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Squid-Cache | Squid | from 3.0 through 3.5.27 from 4.0 through 4.0.22 |
| Debian | Debian Linux | Versions 7.0, 8.0, 9.0 |
| Canonical | Ubuntu Linux | Versions 14.04, 16.04, 17.10 |
References
- NVD record
- CVE.org record
- http://www.squid-cache.org/Advisories/SQUID-2018_1.txt
- http://www.squid-cache.org/Versions/
- https://lists.debian.org/debian-lts-announce/2018/02/msg00001.html
- https://usn.ubuntu.com/3557-1/
- https://usn.ubuntu.com/4059-2/
- https://www.debian.org/security/2018/dsa-4122
- http://www.squid-cache.org/Advisories/SQUID-2018_1.txt
- http://www.squid-cache.org/Versions/
- https://lists.debian.org/debian-lts-announce/2018/02/msg00001.html
- https://usn.ubuntu.com/3557-1/
- https://usn.ubuntu.com/4059-2/
- https://www.debian.org/security/2018/dsa-4122