NetSight
medium5.5

CVE-2018-1000079

RubyGems Path Traversal vulnerability

Impact

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem writing to arbitrary filesystem locations during installation. This attack appears to be exploitable via installation of a malicious gem. This vulnerability is fixed in 2.7.6.

Affected packages

EcosystemPackageAffectedFixed in
rubygemsrubygems-update< 2.7.62.7.6
mavenorg.jruby:jruby-stdlib< 9.1.16.09.1.16.0

Affected products

VendorProductAffected versions
RubygemsRubygems
through 2.2.9
through 2.3.6
through 2.4.3
through 2.5.0

Weakness classification

References