NetSight
high7.5

CVE-2018-1000127

memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to ite…

Impact

memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.

Affected products

VendorProductAffected versions
MemcachedMemcached
before 1.4.37
DebianDebian Linux
Versions 7.0, 8.0, 9.0
CanonicalUbuntu Linux
Versions 14.04, 16.04, 17.10
RedhatOpenstack
Version 10

Weakness classification

References