NetSight
high7.5

CVE-2018-1000165

LightSAML Incorrect Access Control vulnerability

Impact

LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in signature validation in readers in `src/LightSaml/Model/XmlDSig/` that can result in impersonation of any user from Identity Provider. This vulnerability appears to have been fixed in 1.3.5 and later.

Affected packages

EcosystemPackageAffectedFixed in
composerlightsaml/lightsaml< 1.3.51.3.5

Affected products

VendorProductAffected versions
LightsamlLightsaml
before 1.3.5

Weakness classification

References