high7.5
CVE-2018-1000168
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segment…
Impact
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Nghttp2 | Nghttp2 | from 1.10.0 through 1.31.0 |
| Nodejs | Node.Js | from 6.0.0 through 6.8.1 from 8.4.0 through 8.17.0 from 9.0.0 through 9.11.2 from 10.0.0 before 10.4.1 |
| Debian | Debian Linux | Version 9.0 |
Weakness classification
References
- NVD record
- CVE.org record
- http://www.securityfocus.com/bid/103952
- https://access.redhat.com/errata/RHSA-2019:0366
- https://access.redhat.com/errata/RHSA-2019:0367
- https://lists.debian.org/debian-lts-announce/2021/10/msg00011.html
- https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
- http://www.securityfocus.com/bid/103952
- https://access.redhat.com/errata/RHSA-2019:0366
- https://access.redhat.com/errata/RHSA-2019:0367
- https://lists.debian.org/debian-lts-announce/2021/10/msg00011.html
- https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/