high7.8
CVE-2018-1000401
Jenkins AWS CodePipeline Plugin has Insufficiently Protected Credentials
Impact
Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | com.amazonaws:aws-codepipeline | < 0.37 | 0.37 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Jenkins | Aws Codepipeline | through 0.36 |