medium5.5
CVE-2018-1000524
miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer_resize() function in map_engine.c that can result in remote denial of s…
Impact
miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer_resize() function in map_engine.c that can result in remote denial of service. This attack appear to be exploitable via the victim must load a specially-crafted map which calls SetLayerSize in its entry script. This vulnerability appears to have been fixed in 5.0.3, 5.1.5, 5.2.10 and later.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Spheredev | Minisphere | through 5.2.9 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/fatcerberus/minisphere/commit/252c1ca184cb38e1acb917aa0e451c5f08519996
- https://github.com/fatcerberus/minisphere/pull/268
- https://github.com/fatcerberus/minisphere/commit/252c1ca184cb38e1acb917aa0e451c5f08519996
- https://github.com/fatcerberus/minisphere/pull/268