NetSight
high7.5

CVE-2018-1000656

Flask is vulnerable to Denial of Service via incorrect encoding of JSON data

Impact

The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3.

Affected packages

EcosystemPackageAffectedFixed in
pipflask< 0.12.30.12.3

Affected products

VendorProductAffected versions
PalletsprojectsFlask
before 0.12.3
NetappActive Iq
All versions
NetappHyper Converged Infrastructure
All versions
NetappOntap Select Deploy Utility
All versions

Weakness classification

References