high5.9
CVE-2018-1000808
Pyopenssl Incorrect Memory Management
Impact
It was discovered that pyOpenSSL incorrectly handled memory when performing operations on a PKCS #12 store. A remote attacker could possibly use this issue to cause pyOpenSSL to consume resources, resulting in a denial of service. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection that would cause the calling application to reload certificates from a PKCS #12 store. This vulnerability appears to have been fixed in 17.5.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | pyopenssl | < 17.5.0 | 17.5.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Pyopenssl Project | Pyopenssl | before 17.5.0 |
| Canonical | Ubuntu Linux | Version 16.04 |
| Redhat | Gluster Storage | Version 3.0 |
| Redhat | Openstack | Version 13 |
| Redhat | Enterprise Linux Desktop | Version 7.0 |
| Redhat | Enterprise Linux Server | Version 7.0 |
| Redhat | Enterprise Linux Workstation | Version 7.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.html
- https://access.redhat.com/errata/RHSA-2019:0085
- https://github.com/pyca/pyopenssl/pull/723
- https://usn.ubuntu.com/3813-1/
- https://github.com/advisories/GHSA-2rcm-phc9-3945
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000808
- https://github.com/pyca/pyopenssl/commit/e73818600065821d588af475b024f4eb518c3509
- https://github.com/pypa/advisory-database/tree/main/vulns/pyopenssl/PYSEC-2018-24.yaml
- https://usn.ubuntu.com/3813-1