high8.8
CVE-2018-1000849
Alpine Linux version Versions prior to 2.6.10, 2.7.6, and 2.10.1 contains a Other/Unknown vulnerability in apk-tools (Alpine Linux' package manager) that can r…
Impact
Alpine Linux version Versions prior to 2.6.10, 2.7.6, and 2.10.1 contains a Other/Unknown vulnerability in apk-tools (Alpine Linux' package manager) that can result in Remote Code Execution. This attack appear to be exploitable via A specially crafted APK-file can cause apk to write arbitrary data to an attacker-specified file, due to bugs in handling long link target name and the way a regular file is extracted.. This vulnerability appears to have been fixed in 2.6.10, 2.7.6, and 2.10.1.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Alpinelinux | Alpine Linux | before 2.6.10 from 2.7.0 before 2.7.6 from 2.7.7 before 2.10.1 |
Weakness classification
References
- NVD record
- CVE.org record
- https://alpinelinux.org/posts/Alpine-3.8.1-released.html
- https://git.alpinelinux.org/cgit/apk-tools/commit/?id=6484ed9849f03971eb48ee1fdc21a2f128247eb1
- https://justi.cz/security/2018/09/13/alpine-apk-rce.html
- https://alpinelinux.org/posts/Alpine-3.8.1-released.html
- https://git.alpinelinux.org/cgit/apk-tools/commit/?id=6484ed9849f03971eb48ee1fdc21a2f128247eb1
- https://justi.cz/security/2018/09/13/alpine-apk-rce.html