NetSight
high6.5

CVE-2018-1000872

PyKMIP Denial of service vulnerability

Impact

OpenKMIP PyKMIP version All versions before 0.8.0 contains a CWE 399: Resource Management Errors (similar issue to CVE-2015-5262) vulnerability in PyKMIP server that can result in DOS: the server can be made unavailable by one or more clients opening all of the available sockets. This attack appear to be exploitable via A client or clients open sockets with the server and then never close them. This vulnerability appears to have been fixed in 0.8.0.

Affected packages

EcosystemPackageAffectedFixed in
pippykmip< 0.8.00.8.0

Affected products

VendorProductAffected versions
Pykmip ProjectPykmip
before 0.8.0

Weakness classification

References