NetSight
high5.6

CVE-2018-16487

Prototype Pollution in lodash

Impact

Versions of `lodash` before 4.17.11 are vulnerable to prototype pollution. The vulnerable functions are 'defaultsDeep', 'merge', and 'mergeWith' which allow a malicious user to modify the prototype of `Object` via `{constructor: {prototype: {...}}}` causing the addition or modification of an existing property that will exist on all objects. ## Recommendation Update to version 4.17.11 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmlodash< 4.17.114.17.11
rubygemslodash-rails< 4.17.114.17.11

Affected products

VendorProductAffected versions
LodashLodash
before 4.17.11

Weakness classification

References