NetSight
high8.8

CVE-2018-19296

Phar object injection in PHPMailer

Impact

PHPMailer versions prior to 6.0.6 and 5.2.27 are vulnerable to an object injection attack by passing phar:// paths into `addAttachment()` and other functions that may receive unfiltered local paths, possibly leading to RCE. See [this article](https://knasmueller.net/5-answers-about-php-phar-exploitation) for more info on this type of vulnerability. Mitigated by blocking the use of paths containing URL-protocol style prefixes such as `phar://`. Reported by Sehun Oh of cyberone.kr. ### Impact Object injection, possible remote code execution ### Patches Fixed in 6.0.6 and 5.2.27 ### Workarounds Validate and sanitise user input before using. ### References https://nvd.nist.gov/vuln/detail/CVE-2018-19296 ### For more information If you have any questions or comments about this advisory: * Open a private issue in [the PHPMailer project](https://github.com/PHPMailer/PHPMailer)

Affected packages

EcosystemPackageAffectedFixed in
composerphpmailer/phpmailer>= 5.0.0, < 5.2.275.2.27

Affected products

VendorProductAffected versions
Phpmailer ProjectPhpmailer
before 5.2.27
from 6.0.0 before 6.0.6
DebianDebian Linux
Versions 8.0, 9.0
FedoraprojectFedora
Versions 33, 34
WordpressWordpress
from 3.7 through 5.7

Weakness classification

References