NetSight
high7.5

CVE-2018-3711

Denial of Service vulnerability with large JSON payloads in fastify

Impact

Affected versions of `fastify` are vulnerable to a denial of service when processing a request with `Content-Type` set to `application/json` and a very large payload. ## Recommendation Update to version 0.38.0 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmfastify<= 0.37.00.38.0

Affected products

VendorProductAffected versions
FastifyFastify
before 0.38.0

Weakness classification

References