medium6.5
CVE-2018-3721
Prototype Pollution in lodash
Impact
Versions of `lodash` before 4.17.5 are vulnerable to prototype pollution. The vulnerable functions are 'defaultsDeep', 'merge', and 'mergeWith' which allow a malicious user to modify the prototype of `Object` via `__proto__` causing the addition or modification of an existing property that will exist on all objects. ## Recommendation Update to version 4.17.5 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | lodash | < 4.17.5 | 4.17.5 |
| rubygems | lodash-rails | < 4.17.5 | 4.17.5 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Lodash | Lodash | before 4.17.5 |
| Netapp | Active Iq Unified Manager | All versions |
| Netapp | System Manager | Version 9.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/lodash/lodash/commit/d8e069cc3410082e44eb18fcf8e7f3d08ebe1d4a
- https://hackerone.com/reports/310443
- https://security.netapp.com/advisory/ntap-20190919-0004/
- https://github.com/advisories/GHSA-fvqr-27wr-82fm
- https://nvd.nist.gov/vuln/detail/CVE-2018-3721
- https://security.netapp.com/advisory/ntap-20190919-0004
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/lodash-rails/CVE-2018-3721.yml