NetSight
critical9.8

CVE-2018-3757

Command Injection in pdf-image

Impact

Versions of `pdf-image` before 2.0.0 are vulnerable to command injection. This vulnerability is exploitable if the attacker has control over the `pdfFilePath` variable passed into `pdf-image`. ## Recommendation Update to version 2.0.0 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmpdf-image< 2.0.02.0.0

Affected products

VendorProductAffected versions
Pdf-Image ProjectPdf-Image
Version 2.0.0

Weakness classification

References