medium5.3
CVE-2018-3778
Improper Authorization in aedes
Impact
Versions of `aedes` before 0.35.1 does not respect its own authorization rules when a client sets a `Last Will`. ## Recommendation Update to version 0.35.1 or later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | aedes | < 0.35.1 | 0.35.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Aedes Project | Aedes | before 0.35.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/mcollina/aedes/issues/211
- https://github.com/mcollina/aedes/issues/212
- https://github.com/nodejs/security-wg/blob/master/vuln/npm/457.json
- https://github.com/advisories/GHSA-4cmx-hrq9-c23p
- https://nvd.nist.gov/vuln/detail/CVE-2018-3778
- https://github.com/moscajs/aedes/issues/211
- https://github.com/moscajs/aedes/issues/212
- https://github.com/moscajs/aedes/commit/ffbc1702bb24b596afbb96407cc6db234a4044a8