NetSight
critical9.8

CVE-2018-3786

Command Injection in egg-scripts

Impact

Versions of `egg-scripts` before 2.8.1 are vulnerable to command injection. This is only exploitable if a malicious argument is provided on the command line. Example: `eggctl start --daemon --stderr='/tmp/eggctl_stderr.log; touch /tmp/malicious'` ## Recommendation Update to version 2.8.1 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmegg-scripts< 2.8.12.8.1

Affected products

VendorProductAffected versions
EggjsEgg-Scripts
before 2.8.1

Weakness classification

References