medium6.1
CVE-2018-9861
Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in …
Impact
Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Ckeditor | Enhanced Image | from 4.5.10 before 4.9.2 |
| Drupal | Drupal | from 8.0.0 before 8.4.7 from 8.5.0 before 8.5.2 |
Weakness classification
References
- NVD record
- CVE.org record
- http://www.securityfocus.com/bid/103924
- https://github.com/ckeditor/ckeditor-dev/blob/master/CHANGES.md
- https://www.drupal.org/sa-core-2018-003
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
- http://www.securityfocus.com/bid/103924
- https://github.com/ckeditor/ckeditor-dev/blob/master/CHANGES.md
- https://www.drupal.org/sa-core-2018-003
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html