high7.5
CVE-2018-9988
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
Impact
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Arm | Mbed Tls | before 2.1.11 from 2.7.0 before 2.7.2 |
| Trustedfirmware | Mbed Tls | Version 2.8.0 |
| Debian | Debian Linux | Versions 8.0, 9.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/ARMmbed/mbedtls/commit/027f84c69f4ef30c0693832a6c396ef19e563ca1
- https://github.com/ARMmbed/mbedtls/commit/a1098f81c252b317ad34ea978aea2bc47760b215
- https://lists.debian.org/debian-lts-announce/2018/09/msg00029.html
- https://lists.debian.org/debian-lts-announce/2021/11/msg00021.html
- https://tls.mbed.org/tech-updates/releases/mbedtls-2.8.0-2.7.2-and-2.1.11-released
- https://github.com/ARMmbed/mbedtls/commit/027f84c69f4ef30c0693832a6c396ef19e563ca1
- https://github.com/ARMmbed/mbedtls/commit/a1098f81c252b317ad34ea978aea2bc47760b215
- https://lists.debian.org/debian-lts-announce/2018/09/msg00029.html
- https://lists.debian.org/debian-lts-announce/2021/11/msg00021.html
- https://tls.mbed.org/tech-updates/releases/mbedtls-2.8.0-2.7.2-and-2.1.11-released