NetSight
medium4.9

CVE-2019-0226

Apache Karaf vulnerable to relative path traversal

Impact

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.karaf.config:org.apache.karaf.config.core< 4.2.54.2.5

Affected products

VendorProductAffected versions
ApacheKaraf
before 4.2.5

Weakness classification

References