medium6.5
CVE-2019-1000002
Gitea Arbitrary File Delete Vulnerability
Impact
Gitea version 1.6.2 and earlier contains a Incorrect Access Control vulnerability in Delete/Edit file functionallity that can result in the attacker deleting files outside the repository he/she has access to. This attack appears to be exploitable via the attacker must get write access to "any" repository including self-created ones. This vulnerability appears to have been fixed in 1.6.3, 1.7.0-rc2.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | code.gitea.io/gitea | <= 1.6.2 | 1.6.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Gitea | Gitea | through 1.6.2 |