critical9.8
CVE-2019-1010161
perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control.
Impact
perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Perl-Crypt-Jwt Project | Perl-Crypt-Jwt | through 0.022 |