medium6.1
CVE-2019-1010261
Gitea XSS Vulnerability
Impact
Gitea 1.7.0 and earlier is affected by: Cross Site Scripting (XSS). The impact is: Attacker is able to have victim execute arbitrary JS in browser. The component is: go-get URL generation - PR to fix: https://github.com/go-gitea/gitea/pull/5905. The attack vector is: victim must open a specifically crafted URL. The fixed version is: 1.7.1 and later.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | code.gitea.io/gitea | <= 1.7.0 | 1.7.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Gitea | Gitea | through 1.7.0 |