NetSight
medium5.5

CVE-2019-10157

Forced Logout in keycloak-connect

Impact

Versions of `keycloak-connect` prior to 4.4.0 are vulnerable to Forced Logout. The package fails to validate JWT signatures on the `/k_logout` route, allowing attackers to logout users and craft malicious JWTs with NBF values that prevent user access indefinitely. ## Recommendation Upgrade to version 4.4.0 or later.

Affected packages

EcosystemPackageAffectedFixed in
npmkeycloak-connect< 4.8.34.8.3

Affected products

VendorProductAffected versions
RedhatKeycloak
before 4.8.3
RedhatSingle Sign-On
before 7.3.2

Weakness classification

References