medium5.4
CVE-2019-1020003
Cross-site scripting invenio-records
Impact
## Cross-Site Scripting (XSS) vulnerability in administration interface ### Impact A Cross-Site Scripting (XSS) vulnerability was discovered when rendering JSON for a record in the administration interface. The vulnerability could be exploited by e.g. a user who had access to upload a new record, that an admin user would then later view in the admin interface. ### Patches All supported versions of Invenio-Records have been patched. You should upgrade to either v1.0.1, v1.1.1 or v1.2.2 ### For more information If you have any questions or comments about this advisory: * Email us at [info@inveniosoftware.org](mailto:info@inveniosoftware.org)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | invenio-records | < 1.0.2 | 1.0.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Inveniosoftware | Invenio-Records | through 1.0.1 Versions 1.1.0, 1.2.0, 1.2.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/inveniosoftware/invenio-records/security/advisories/GHSA-vxh3-mvv7-265j
- https://github.com/advisories/GHSA-vxh3-mvv7-265j
- https://nvd.nist.gov/vuln/detail/CVE-2019-1020003
- https://github.com/pypa/advisory-database/tree/main/vulns/invenio-records/PYSEC-2019-27.yaml